Back to overview
Degraded
docuseal.com latency increased
Mar 12 at 07:45pm UTC
Affected services
docuseal.com
api.docuseal.com
Resolved
Mar 12 at 07:55pm UTC
docuseal.com latency is back to norm
Affected services
Created
Mar 12 at 07:45pm UTC
Dashboard and API response takes more time than usual on docuseal.com. All services continue operating but slower.
Affected services