Back to overview
Degraded

AWS outage in the US-EAST-1 Region causes email sending delay

Oct 20 at 07:16am UTC
Affected services
docuseal.com
api.docuseal.com

Resolved
Oct 20 at 09:29am UTC

AWS outage has been resolved, all delayed emails have been delivered to the recipients.

Created
Oct 20 at 07:16am UTC

https://health.aws.amazon.com/health/status we're monitoring AWS status updates regarding this issue. The email sending is delayed. All emails will be sent once the AWS us-east-1 issues are resolved.