Back to overview
Degraded
Users are experiencing slower than usual API queries and timeouts
Mar 06 at 12:53pm UTC
Affected services
docuseal.com
Resolved
Mar 06 at 01:08pm UTC
Everything is back to normal
Affected services
Created
Mar 06 at 12:53pm UTC
We're investigating the issue
Affected services